summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b544444db1..36434a4707 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7166,8 +7166,10 @@ def customize_build(EXTENSIONS, OPTIONS):
     del EXTENSIONS['zfp']
     del EXTENSIONS['zopfli']
     OPTIONS['cythonize']
-")))
-             #t)))))
+")))))
+         ;; XXX: The installed scripts import packages that depend on
+         ;; this package; disable import check to avoid the cycle.
+         (delete 'sanity-check))))
     (inputs
       (list c-blosc
             giflib
@@ -7182,6 +7184,7 @@ def customize_build(EXTENSIONS, OPTIONS):
             zlib
             `(,zstd "lib")))
     (propagated-inputs
+      ;; For the Python library.
       (list python-numpy))
     (native-inputs
       ;; For building.