summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 10 insertions, 19 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1f98210b8c..6ae8280ee2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10525,32 +10525,23 @@ contains all syscalls and related types.")
 
 (define-public rust-cloudflare-zlib-sys-0.2
   (package
+    (inherit rust-cloudflare-zlib-sys-0.3)
     (name "rust-cloudflare-zlib-sys")
     (version "0.2.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "cloudflare-zlib-sys" version))
-        (file-name
-         (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32
-          "01lwfd15ijw4d8jsqp87yv4wpmzcp84qm0qqwy3yxmm0fjr5q6by"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "cloudflare-zlib-sys" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "01lwfd15ijw4d8jsqp87yv4wpmzcp84qm0qqwy3yxmm0fjr5q6by"))))
     ;; This crate bundles cloudflare's fork of zlib, so we don't unbundle it.
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
-       (("rust-cc" ,rust-cc-1))))
-    (home-page "https://github.com/cloudflare/zlib")
-    (synopsis
-     "Cloudflare fork of zlib with massive performance improvements")
-    (description
-     "Cloudflare fork of zlib with massive performance improvements.")
-    (license
-      (list license:expat
-            license:asl2.0
-            license:zlib))))
+       (("rust-cc" ,rust-cc-1))))))
 
 (define-public rust-cmac-0.5
   (package