summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lua.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index e4b3818faa..0100ed2dd3 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1094,7 +1094,13 @@ shell command executions.")
              #t))
          (delete 'check)
          (add-after 'install 'check
-           (assoc-ref %standard-phases 'check)))))
+           (assoc-ref %standard-phases 'check))
+         (add-after 'install 'install-manpage
+           (lambda* (#:key outputs #:allow-other-keys)
+             (install-file "fennel.1"
+                           (string-append (assoc-ref outputs "out")
+                                          "/share/man/man1"))
+             #t)))))
     (inputs `(("lua" ,lua)))
     (home-page "https://fennel-lang.org/")
     (synopsis "Lisp that compiles to Lua")