summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ab6b11c3c6..da83646f95 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2880,6 +2880,12 @@ supports url redirection and retries, and also gzip and deflate decoding.")
      '(#:tests? #f
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'use-recent-pyyaml
+           (lambda _
+             (substitute* '("awscli.egg-info/requires.txt"
+                            "setup.cfg"
+                            "setup.py")
+               (("<5.5") "<=6"))))
          (add-after 'unpack 'fix-reference-to-groff
            (lambda _
              (substitute* "awscli/help.py"
@@ -2892,7 +2898,7 @@ supports url redirection and retries, and also gzip and deflate decoding.")
            python-botocore-for-awscli
            python-s3transfer
            python-docutils-0.15
-           python-pyyaml-for-awscli
+           python-pyyaml
            python-rsa))
     (native-inputs
      (list groff))