summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5de9ff1bb2..8e57f7abd0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27472,7 +27472,7 @@ information for your operating system.")
        (uri (pypi-uri "canonicaljson" version))
        (sha256
         (base32 "0j5lq191jkd483q6xzc16c9fahxf15lrv03mvah9ka3lq85pcnfa"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
       #:phases
@@ -27481,21 +27481,7 @@ information for your operating system.")
            (lambda _
              ;; Permit newer versions of setuptools_scm
              (substitute* "pyproject.toml"
-               ((">= 2.0.0, <3") ">= 2.0.0"))))
-          (replace 'build
-            (lambda _
-              ;; ZIP does not support timestamps before 1980.
-              (setenv "SOURCE_DATE_EPOCH" "315532800")
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest"))))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
+               ((">= 2.0.0, <3") ">= 2.0.0")))))))
     (native-inputs
      (list python-pypa-build python-pytest python-setuptools python-setuptools-scm))
     (propagated-inputs