summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 829b216cf3..55c489a5d7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -463,7 +463,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
     (native-inputs
      `(,@(if (member (%current-system) (package-supported-systems go-1.4))
            `(("go" ,go-1.4))
-           `(("go" ,gccgo-10)))
+           `(("go" ,gccgo-12)))
        ("go-skip-gc-test.patch" ,(search-patch "go-skip-gc-test.patch"))
        ,@(match (%current-system)
            ((or "armhf-linux" "aarch64-linux")
@@ -837,13 +837,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                   "README.md" "SECURITY.md"))))))))
     (inputs (if (not (target-arm?))
               (alist-delete "gcc:lib" (package-inputs go-1.16))
-              (package-inputs go-1.16)))
-    (native-inputs
-     (if (not (member (%current-system) (package-supported-systems go-1.4)))
-       ;; gccgo-10.4, 11.3 and lower has a bug which causes bootstrapping
-       ;; to fail. Use go-1.16 until we have a newer version available.
-       (alist-replace "go" (list go-1.16) (package-native-inputs go-1.16))
-       (package-native-inputs go-1.16)))))
+              (package-inputs go-1.16)))))
 
 (define-public go-1.18
   (package