summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/game-development.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 774564ed2a..0a78ec6ad2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2178,12 +2178,12 @@ of the others")
         #~(modify-phases %standard-phases
             (delete 'configure)         ; no configure-script
             (replace 'install
-              (lambda* (#:key outputs #:allow-other-keys)
-                (invoke "make" "copyfiles" "CC=gcc"
-                        "USE_INTERNAL_LIBS=0"
-                        (string-append "COPYDIR="
-                                       (assoc-ref outputs "out")
-                                       "/bin")))))))
+              (lambda* (#:key make-flags outputs #:allow-other-keys)
+                (apply invoke "make" "copyfiles"
+                       (string-append "COPYDIR="
+                                      (assoc-ref outputs "out")
+                                      "/bin")
+                       make-flags))))))
       (home-page "https://ioquake3.org/")
       (synopsis "FPS game engine based on Quake 3")
       (description "ioquake3 is a free software first person shooter engine