summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/terminals.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 7948b86ef1..d3c780acd2 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -24,6 +24,7 @@
 ;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1241,6 +1242,26 @@ an st fork using wld. st is a simple terminal emulator for X originally
 made by suckless.")
     (license license:x11)))
 
+(define-public tio
+  (package
+    (name "tio")
+    (version "1.32")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/tio/tio/releases/download/v"
+             version "/tio-" version ".tar.xz"))
+       (sha256
+        (base32 "0i5fhi4xdk4yznj8wahniizddmx6wlcnnhda1dw9djyajilyvxd8"))))
+    (build-system gnu-build-system)
+    (home-page "https://tio.github.io/")
+    (synopsis "Simple TTY terminal I/O application")
+    (description "tio is a simple TTY terminal application which features a
+straightforward commandline interface to easily connect to TTY devices for
+basic input/output.")
+    (license license:gpl2+)))
+
 (define-public alacritty
   (package
     (name "alacritty")