summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/vnc.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index e06dbcceb9..4795ccc72a 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -283,6 +283,11 @@ application which is needed to connect to VNC servers.")
        ((#:phases phases)
         #~(modify-phases #$phases
             (delete 'check)             ;no test suite
+            (add-after 'unpack 'adjust-pam-config
+              (lambda _
+                (substitute* "tigervnc-client/unix/vncserver/tigervnc.pam"
+                  (("pam_systemd.so")
+                   "pam_elogind.so"))))
             (add-before 'build 'build-tigervnc
               (lambda* (#:key parallel-build? #:allow-other-keys)
                 (mkdir-p "tigervnc-client/build")