summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 4 insertions, 25 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b4861266b..2f2c960656 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2565,37 +2565,16 @@ of @code{xmlfile}.")
                   (replace 'check
                     (lambda _
                       (invoke "pytest"))))))
-    (native-inputs
-     ;; For the test suite.
-     (list python-lxml python-pillow python-pytest))
-    (propagated-inputs
-     (list python-et-xmlfile python-jdcal))
+    (native-inputs (list python-lxml python-pillow python-pytest))
+    (propagated-inputs (list python-et-xmlfile python-jdcal))
     (home-page "https://openpyxl.readthedocs.io")
     (synopsis "Python library to read/write Excel 2010 XLSX/XLSM files")
-    (description "This Python library allows reading and writing to the Excel XLSX, XLSM,
+    (description
+     "This Python library allows reading and writing to the Excel XLSX, XLSM,
 XLTX and XLTM file formats that are defined by the Office Open XML (OOXML)
 standard.")
-    (properties  `((python2-variant . ,(delay python2-openpyxl))))
     (license license:expat)))
 
-(define-public python2-openpyxl
-  (let ((base (package-with-python2
-               (strip-python2-variant python-openpyxl))))
-    (package
-      (inherit base)
-      ;; This is the latest version that has python2 support
-      (version "2.6.4")
-      (source
-        (origin
-          (method url-fetch)
-          (uri (pypi-uri "openpyxl" version))
-          (sha256
-           (base32
-            "1qzjj8nwj4dn0mhq1j64f136afiqqb81lvqiikipz3g1g0b80lqx"))))
-      (arguments
-       `(#:python ,python-2
-         #:tests? #f)))))     ; No test suite.
-
 (define-public python-eventlet
   (package
     (name "python-eventlet")