summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ebook.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 800b518064..778b17c469 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -31,6 +31,7 @@
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
@@ -83,6 +84,7 @@
             (delete-file-recursively "src/unrar")
             (delete-file "src/odf/thumbnail.py")
             (delete-file-recursively "resources/fonts/liberation")
+            (delete-file-recursively "src/chardet")
             (substitute* (find-files "." "\\.py")
               (("calibre\\.ebooks\\.markdown") "markdown"))
             #t))
@@ -121,6 +123,7 @@
        ("podofo" ,podofo)
        ("python" ,python-2)
        ("python2-apsw" ,python2-apsw)
+       ("python2-chardet" ,python2-chardet)
        ("python2-cssselect" ,python2-cssselect)
        ("python2-cssutils" ,python2-cssutils)
        ("python2-dateutil" ,python2-dateutil)