summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/matrix.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 1c19eab5c1..e2c27f5a4c 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -72,7 +72,10 @@
     (build-system python-build-system)
     (arguments
      ;; tests require synapse, creating a circular dependency.
-     '(#:tests? #f))
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  ;; Also, auth_provider.py attempts to import synapse.
+                  (delete 'sanity-check))))
     (propagated-inputs
      (list python-twisted python-ldap3 python-service-identity))
     (home-page "https://github.com/matrix-org/matrix-synapse-ldap3")