summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/gperf.scm54
-rw-r--r--distro/packages/guile.scm5
3 files changed, 57 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 79df0ef45c..489a2fcb85 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,7 @@ MODULES =					\
   distro/packages/bdw-gc.scm			\
   distro/packages/bootstrap.scm			\
   distro/packages/gawk.scm			\
+  distro/packages/gperf.scm			\
   distro/packages/guile.scm			\
   distro/packages/ld-wrapper.scm		\
   distro/packages/libffi.scm			\
diff --git a/distro/packages/gperf.scm b/distro/packages/gperf.scm
new file mode 100644
index 0000000000..392b9dd4fe
--- /dev/null
+++ b/distro/packages/gperf.scm
@@ -0,0 +1,54 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages gperf)
+  #:use-module (guix packages)
+  #:use-module (guix ftp)
+  #:use-module (guix utils)
+  #:use-module (guix build-system gnu))
+
+(define-public gperf
+  (package
+    (name "gperf")
+    (version "3.0.4")
+    (source
+     (origin
+      (method ftp-fetch)
+      (uri (string-append "ftp://ftp.gnu.org/gnu/gperf/gperf-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn"))))
+    (build-system gnu-build-system)
+    (arguments '(#:parallel-tests? #f))
+    (home-page "http://www.gnu.org/software/gperf/")
+    (synopsis
+     "GNU gperf, a perfect hash function generator")
+    (description
+     "GNU gperf is a perfect hash function generator.  For a given
+list of strings, it produces a hash function and hash table, in
+form of C or C++ code, for looking up a value depending on the
+input string.  The hash function is perfect, which means that
+the hash table has no collisions, and the hash table lookup
+needs a single string comparison only.
+
+GNU gperf is highly customizable.  There are options for
+generating C or C++ code, for emitting switch statements or
+nested ifs instead of a hash table, and for tuning the algorithm
+employed by gperf.")
+    (license "GPLv3+")))
diff --git a/distro/packages/guile.scm b/distro/packages/guile.scm
index 9ff17f23d1..d65584f371 100644
--- a/distro/packages/guile.scm
+++ b/distro/packages/guile.scm
@@ -20,6 +20,7 @@
   #:use-module (distro)
   #:use-module (distro packages bdw-gc)
   #:use-module (distro packages gawk)
+  #:use-module (distro packages gperf)
   #:use-module (distro packages libffi)
   #:use-module (distro packages libtool)
   #:use-module (distro packages libunistring)
@@ -29,7 +30,6 @@
   #:use-module (distro packages readline)
   #:use-module (guix packages)
   #:use-module (guix http)
-  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 ;;; Commentary:
@@ -151,8 +151,7 @@ or 2.0."
                "1svlyk5pm4fsdp2g7n6qffdl6fdggxnlicj0jn9s4lxd63gzxy1n"))))
    (build-system gnu-build-system)
    (native-inputs `(("pkgconfig" ,pkg-config)
-                    ("gperf" ,(false-if-exception ; FIXME
-                               (nixpkgs-derivation "gperf")))))
+                    ("gperf" ,gperf)))
    (inputs `(("guile" ,guile)))
    (synopsis "Guile-Reader, a simple framework for building readers for
 GNU Guile")