summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/fontutils.scm1
-rw-r--r--gnu/packages/patches/python-afdko-suppress-copyright-test.patch20
3 files changed, 22 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 597254f831..721a1ae067 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1715,6 +1715,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/python-3-fix-tests.patch			\
   %D%/packages/patches/python-3-hurd-configure.patch		\
   %D%/packages/patches/python-3-no-static-lib.patch		\
+  %D%/packages/patches/python-afdko-suppress-copyright-test.patch	\
   %D%/packages/patches/python-aionotify-0.2.0-py3.8.patch	\
   %D%/packages/patches/python-argcomplete-1.11.1-fish31.patch	\
   %D%/packages/patches/python-cross-compile.patch		\
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 368aad49d6..72621cc006 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -146,6 +146,7 @@ them as it goes.")
        (uri (pypi-uri "afdko" version))
        (sha256
         (base32 "0k1204vykgx32saa495s1lgmz1dixcp8bjiv486imx77killvm02"))
+       (patches (search-patches "python-afdko-suppress-copyright-test.patch"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
diff --git a/gnu/packages/patches/python-afdko-suppress-copyright-test.patch b/gnu/packages/patches/python-afdko-suppress-copyright-test.patch
new file mode 100644
index 0000000000..94cd73d5f7
--- /dev/null
+++ b/gnu/packages/patches/python-afdko-suppress-copyright-test.patch
@@ -0,0 +1,20 @@
+Supress copyright check in tests which can differ based on current year.
+
+  https://github.com/adobe-type-tools/afdko/issues/1589
+
+Adapted from upstream:
+
+  https://github.com/adobe-type-tools/afdko/commit/feebd77d9b6507a0b32f837535511be3c94d9c6f
+
+diff --git a/tests/tx_test.py b/tests/tx_test.py
+--- a/tests/tx_test.py
++++ b/tests/tx_test.py
+@@ -1246,7 +1246,7 @@ def test_ufo_fontinfo_parsing(file, msg, ret_code):
+     if (ret_code == 0):
+         expected_path = generate_ps_dump(expected_path)
+         output_path = generate_ps_dump(output_path)
+-        assert differ([expected_path, output_path])
++        assert differ([expected_path, output_path, '-s'] + PFA_SKIP)
+     else:
+         arg = [TOOL, '-t1', '-f', ufo_input_path]
+         assert subprocess.call(arg) == 6