summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am3
-rw-r--r--guix/build-system.scm34
-rw-r--r--guix/build-system/gnu.scm (renamed from guix/gnu-build-system.scm)12
-rw-r--r--tests/builders.scm7
4 files changed, 52 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 814bd3b355..d41e55a188 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,8 @@
 
 MODULES =					\
   guix/derivations.scm				\
-  guix/gnu-build-system.scm			\
+  guix/build-system.scm				\
+  guix/build-system/gnu.scm			\
   guix/http.scm					\
   guix/store.scm				\
   guix/utils.scm				\
diff --git a/guix/build-system.scm b/guix/build-system.scm
new file mode 100644
index 0000000000..179e7ef2df
--- /dev/null
+++ b/guix/build-system.scm
@@ -0,0 +1,34 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build-system)
+  #:use-module (guix utils)
+  #:export (build-system
+            build-system?
+            build-system-name
+            build-system-description
+            build-system-builder
+            build-system-cross-builder))
+
+(define-record-type* <build-system> build-system make-build-system
+  build-system?
+  (name        build-system-name)         ; symbol
+  (description build-system-description)  ; short description
+  (build       build-system-builder)      ; (store system name source inputs)
+  (cross-build build-system-cross-builder ; (store system x-system ...)
+               (default #f)))
diff --git a/guix/gnu-build-system.scm b/guix/build-system/gnu.scm
index 0311aaa76f..e9eb02f251 100644
--- a/guix/gnu-build-system.scm
+++ b/guix/build-system/gnu.scm
@@ -16,12 +16,14 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (guix gnu-build-system)
+(define-module (guix build-system gnu)
   #:use-module (guix store)
   #:use-module (guix utils)
   #:use-module (guix derivations)
+  #:use-module (guix build-system)
   #:use-module (srfi srfi-1)
-  #:export (gnu-build))
+  #:export (gnu-build
+            gnu-build-system))
 
 ;; Commentary:
 ;;
@@ -63,3 +65,9 @@ input derivation INPUTS, using the usual procedure of the GNU Build System."
                                 #:outputs outputs
                                 #:modules '((guix build gnu-build-system)
                                             (guix build utils))))
+
+(define gnu-build-system
+  (build-system (name 'gnu)
+                (description
+                 "The GNU Build System—i.e., ./configure && make && make install")
+                (build gnu-build)))             ; TODO: add `gnu-cross-build'
diff --git a/tests/builders.scm b/tests/builders.scm
index 851baa9ebf..17bae2c754 100644
--- a/tests/builders.scm
+++ b/tests/builders.scm
@@ -19,7 +19,8 @@
 
 (define-module (test-builders)
   #:use-module (guix http)
-  #:use-module (guix gnu-build-system)
+  #:use-module (guix build-system)
+  #:use-module (guix build-system gnu)
   #:use-module (guix store)
   #:use-module (guix utils)
   #:use-module (guix derivations)
@@ -41,6 +42,10 @@
     (and (build-derivations %store (list drv-path))
          (file-exists? (derivation-path->output-path drv-path)))))
 
+(test-assert "gnu-build-system"
+  (and (build-system? gnu-build-system)
+       (eq? gnu-build (build-system-builder gnu-build-system))))
+
 (test-assert "gnu-build"
   (let* ((url      "http://ftp.gnu.org/gnu/hello/hello-2.8.tar.gz")
          (hash     (nix-base32-string->bytevector