summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am7
-rw-r--r--gnu-system.am2
2 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 25ff2224cc..bc0b95232e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -282,6 +282,13 @@ SUFFIXES = .go
 guix_install_go_files = install-nobase_nodist_guilemoduleDATA
 $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
 
+# The above trick doesn't work for 'config.go' because both 'config.scm' and
+# 'config.go' are listed in $(nobase_nodist_guilemodule_DATA).  Thus, give it
+# special treatment.
+install-data-hook: set-bootstrap-executable-permissions
+	touch "$(DESTDIR)$(guilemoduledir)/guix/config.go"
+
+
 SUBDIRS = po/guix po/packages
 BUILT_SOURCES =
 
diff --git a/gnu-system.am b/gnu-system.am
index e21771c669..ab62510159 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -484,7 +484,7 @@ nodist_bootstrap_mips64el_linux_DATA =					\
 
 # Those files must remain executable, so they remain executable once
 # imported into the store.
-install-data-hook:
+set-bootstrap-executable-permissions:
 	chmod +x $(DESTDIR)$(bootstrapdir)/*/{bash,mkdir,tar,xz}
 
 DISTCLEANFILES =				\