summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 99344b168a..c798cc5e72 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17856,15 +17856,16 @@ patterns.")
                 "1sfhf2ap75qxpnmy1ifgmxqs18rq8mah9mcgkby73vc6h0sw99ws"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:test-target "test"
-       #:make-flags
-       ,#~(list "CC=gcc"
-                "CFLAGS=-fcommon"
-                (string-append "prefix=" #$output "/bin/"))
-       #:phases
-       (modify-phases %standard-phases
+     (list
+      #:test-target "test"
+      #:make-flags
+      #~(list "CC=gcc"
+              "CFLAGS=-fcommon"
+              (string-append "prefix=" #$output "/bin/"))
+      #:phases
+      '(modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda _
              (substitute* "Makefile"
                (("-lhts ") "-lhts -lBigWig ")
                (("install MethylDackel \\$\\(prefix\\)" match)
@@ -17874,7 +17875,7 @@ patterns.")
            htslib-1.9 libbigwig zlib))
     ;; Needed for tests
     (native-inputs
-     `(("python" ,python-wrapper)))
+     (list python-wrapper))
     (home-page "https://github.com/dpryan79/MethylDackel")
     (synopsis "Universal methylation extractor for BS-seq experiments")
     (description