summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rw-r--r--distro/packages/lout.scm (renamed from distro/packages/typesetting.scm)10
-rw-r--r--distro/packages/recutils.scm (renamed from distro/packages/databases.scm)10
-rw-r--r--po/POTFILES.in4
4 files changed, 6 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index 8403081cb7..9b0240a95f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,10 +43,10 @@ MODULES =					\
   guix.scm					\
   distro.scm					\
   distro/packages/base.scm			\
-  distro/packages/databases.scm			\
   distro/packages/guile.scm			\
   distro/packages/ld-wrapper.scm		\
-  distro/packages/typesetting.scm
+  distro/packages/lout.scm			\
+  distro/packages/recutils.scm
 
 GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
 
diff --git a/distro/packages/typesetting.scm b/distro/packages/lout.scm
index 25d8e6119e..3045afa3ab 100644
--- a/distro/packages/typesetting.scm
+++ b/distro/packages/lout.scm
@@ -16,18 +16,12 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (distro packages typesetting)
+(define-module (distro packages lout)
   #:use-module (guix packages)
   #:use-module (guix http)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
-;;; Commentary:
-;;;
-;;; Typesetting-related packages.
-;;;
-;;; Code:
-
 (define-public lout
   ;; This one is a bit tricky, because it doesn't follow the GNU Build System
   ;; rules.  Instead, it has a makefile that has to be patched to set the
@@ -131,5 +125,3 @@ outcome of an eight-year research project that went back to the
 beginning.")
     (license "GPLv3+")
     (home-page "http://savannah.nongnu.org/projects/lout/"))))
-
-;;; typesetting.scm ends here
diff --git a/distro/packages/databases.scm b/distro/packages/recutils.scm
index c1dc9260a9..6221ee07c9 100644
--- a/distro/packages/databases.scm
+++ b/distro/packages/recutils.scm
@@ -16,19 +16,13 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (distro packages databases)
+(define-module (distro packages recutils)
   #:use-module (distro)
   #:use-module (guix packages)
   #:use-module (guix http)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
-;;; Commentary:
-;;;
-;;; Database management software and related packages.
-;;;
-;;; Code:
-
 (define-public recutils
   (package
    (name "recutils")
@@ -56,5 +50,3 @@ text-based databases called recfiles.  The data is stored as a sequence of
 records, each record containing an arbitrary number of named fields.")
    (license "GPLv3+")
    (home-page "http://www.gnu.org/software/recutils/")))
-
-;;; databases.scm ends here
diff --git a/po/POTFILES.in b/po/POTFILES.in
index 887b7106ee..fcc84f32f0 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,9 +1,9 @@
 # List of source files which contain translatable strings.
 distro.scm
 distro/packages/base.scm
-distro/packages/databases.scm
 distro/packages/guile.scm
-distro/packages/typesetting.scm
+distro/packages/lout.scm
+distro/packages/recutils.scm
 guix/ui.scm
 guix-build.in
 guix-download.in