summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/virtualization.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 64a26edb02..927be39676 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013-2017, 2020-2022 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2018. 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
@@ -302,7 +302,11 @@
                 ;; Comment out the test-char test, which needs networking and
                 ;; fails within the build environment.
                 ((".*'test-char':.*" all)
-                 (string-append "# " all)))))
+                 (string-append "# " all)))
+              (substitute* "tests/qtest/meson.build"
+                ;; These tests fail to get the expected number of tests
+                ;; on arm platforms.
+                (("'arm-cpu-features',") ""))))
           #$@(if (target-riscv64?)
                  '((add-after 'unpack 'disable-some-tests
                      (lambda _