summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--guix/upstream.scm4
-rw-r--r--tests/upstream.scm49
3 files changed, 52 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f8e57c9cc..f67de43f48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -225,6 +225,7 @@ SCM_TESTS =					\
   tests/grafts.scm				\
   tests/ui.scm					\
   tests/records.scm				\
+  tests/upstream.scm				\
   tests/utils.scm				\
   tests/build-utils.scm				\
   tests/packages.scm				\
diff --git a/guix/upstream.scm b/guix/upstream.scm
index c62667dd01..cea23feb82 100644
--- a/guix/upstream.scm
+++ b/guix/upstream.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2010, 2011, 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2010, 2011, 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -99,7 +99,7 @@ correspond to the same version."
                                       (upstream-source-urls head)))
                         (signature-urls
                          (let ((one (upstream-source-signature-urls release))
-                               (two (upstream-source-signature-urls release)))
+                               (two (upstream-source-signature-urls head)))
                            (and one two (append one two)))))
                        tail)
                  (cons release result)))
diff --git a/tests/upstream.scm b/tests/upstream.scm
new file mode 100644
index 0000000000..eb18dd6193
--- /dev/null
+++ b/tests/upstream.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-upstream)
+  #:use-module (guix upstream)
+  #:use-module (guix tests)
+  #:use-module (srfi srfi-64))
+
+
+(test-begin "upstream")
+
+(test-equal "coalesce-sources same version"
+  (list (upstream-source
+         (package "foo") (version "1")
+         (urls '("ftp://example.org/foo-1.tar.xz"
+                 "ftp://example.org/foo-1.tar.gz"))
+         (signature-urls '("ftp://example.org/foo-1.tar.xz.sig"
+                           "ftp://example.org/foo-1.tar.gz.sig"))))
+
+  (coalesce-sources (list (upstream-source
+                           (package "foo") (version "1")
+                           (urls '("ftp://example.org/foo-1.tar.gz"))
+                           (signature-urls
+                            '("ftp://example.org/foo-1.tar.gz.sig")))
+                          (upstream-source
+                           (package "foo") (version "1")
+                           (urls '("ftp://example.org/foo-1.tar.xz"))
+                           (signature-urls
+                            '("ftp://example.org/foo-1.tar.xz.sig"))))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))