summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--NEWS25
-rw-r--r--gnu/packages/package-management.scm6
2 files changed, 25 insertions, 6 deletions
diff --git a/NEWS b/NEWS
index 62b599c9c9..122c184f65 100644
--- a/NEWS
+++ b/NEWS
@@ -69,8 +69,19 @@ guix-build-coordinator-agent, guix-build-coordinator-queue-builds, hostapd,
 hurd-console, hurd-getty, hurd-vm, lxqt, rshiny, secret-service,
 simulated-wifi, udev-rules, unattended-upgrade, webssh, zram
 
-*** XXX new packages
-*** XXX package updates
+*** 1999 new packages
+*** 3652 package updates
+
+Noteworthy updates:
+bash 5.0.16, binutils 2.34, cups 2.3.3, emacs 27.1, enlightenment 0.24.2,
+gcc-toolchain 10.2.0, gdb 10.1, ghc 8.8.3, gimp 2.10.22, glibc 2.31,
+gnome 3.34.2, gnupg 2.2.23, go 1.14.10, guile 3.0.4,
+icecat 78.4.0-guix0-preview1, inkscape 1.0.1, julia 1.5.2,
+libreoffice 6.4.6.2, linux-libre 5.9.3, mate 1.24.1, ocaml 4.09.0,
+openjdk 14.0, perl 5.30.2, python2 2.7.17, python 3.8.2, racket 7.8,
+rust 1.46.0, r 4.0.3, sbcl 2.0.10, shepherd 0.8.1, xfce 4.14.2,
+xorg-server 1.20.8
+
 
 ** Programming interfaces
 *** New ‘maven-build-system’, for packages built with Maven
@@ -144,7 +155,15 @@ simulated-wifi, udev-rules, unattended-upgrade, webssh, zram
     (<https://bugs.gnu.org/43744>)
 
 ** Native language support
-*** TODO populate
+*** Updated translations of the manual
+
+The manual is fully translated into French, German, and Spanish, and has
+preliminary translations into Chinese and Russian.
+
+*** Updated translations of messages
+
+This version of Guix is fully translated in French, German, and Spanish, and
+partially translated in 11 other languages.
 
 * Changes in 1.1.0 (since 1.0.1)
 ** Package management
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 4a6881d475..6fd789ef53 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -130,8 +130,8 @@
   ;; Latest version of Guix, which may or may not correspond to a release.
   ;; Note: the 'update-guix-package.scm' script expects this definition to
   ;; start precisely like this.
-  (let ((version "1.2.0rc2")
-        (commit "0d4b1afb6bfa4bdeade2cb6409ece9467d513e39")
+  (let ((version "1.2.0")
+        (commit "bd96e6d34e4e65dc37eaae7302033d0da287c1e2")
         (revision 1))
     (package
       (name "guix")
@@ -148,7 +148,7 @@
                       (commit commit)))
                 (sha256
                  (base32
-                  "1d0pifzrr14f1n0fn21rlh0hzfjvfsavf9as1vcjga47bdjjvrpp"))
+                  "0j27yw6s89rni39dmjdz3i617ddr2yi5y5hj0i2a7sw8fn215hp4"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (build-system gnu-build-system)
       (arguments