summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/chicken.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 782bca7427..b148c88303 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -174,6 +174,30 @@ a characters and be compared to other character sets")
     (license (license:non-copyleft
               "http://wiki.call-cc.org/eggref/5/srfi-14#license"))))
 
+(define-public chicken-srfi-18
+  (package
+    (name "chicken-srfi-18")
+    (version "0.1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (egg-uri "srfi-18" version))
+              (sha256
+               (base32
+                "0v2pkdck0ji1wiqgg8sg4z6rbkj2qw4vy4b9lx0w0pmhlxqpg1xd"))))
+    (build-system chicken-build-system)
+    (arguments
+     `(#:egg-name "srfi-18"))
+    (native-inputs (list chicken-compile-file))
+    (home-page "https://wiki.call-cc.org/egg/srfi-18")
+    (synopsis "Multithreading package, largely following SRFI-18")
+    (description "The threads implemented in CHICKEN are so called \"green\"
+threads, based on first-class continuations.  Native threads that map directly
+to the threads provided by the operating system are not supported.  The
+advantage of this is that threads are very lightweight and somewhat larger
+degree of determinism.  The disadvantage is that execution of Scheme code on
+multiple processor cores is not available.")
+    (license license:bsd-3)))
+
 (define-public chicken-srfi-69
   (package
     (name "chicken-srfi-69")