summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/patches/python-unittest2-python3-compat.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-unittest2-python3-compat.patch b/gnu/packages/patches/python-unittest2-python3-compat.patch
index fe0afe559a..68fbccacd0 100644
--- a/gnu/packages/patches/python-unittest2-python3-compat.patch
+++ b/gnu/packages/patches/python-unittest2-python3-compat.patch
@@ -32,3 +32,15 @@ index 683f662..347eea5 100644
      def test_loadTestsFromNames__relative_malformed_name(self):
          loader = unittest.TestLoader()
  
+diff --git a/unittest2/compatibility.py b/unittest2/compatibility.py
+index 9e5f1a5..2d20c19 100644
+--- a/unittest2/compatibility.py
++++ b/unittest2/compatibility.py
+@@ -140,6 +140,6 @@ except ImportError:
+ ###  ChainMap (helper for configparser and string.Template)
+ ########################################################################
+ 
+-class ChainMap(collections.MutableMapping):
++class ChainMap(collections.abc.MutableMapping):
+     ''' A ChainMap groups multiple dicts (or other mappings) together
+     to create a single, updateable view.