summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/apparmor.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/apparmor.scm b/gnu/packages/apparmor.scm
index 9b2019d296..ddbd9eb7a9 100644
--- a/gnu/packages/apparmor.scm
+++ b/gnu/packages/apparmor.scm
@@ -109,7 +109,10 @@ AppArmor supplements the traditional Unix discretionary access control (DAC)
 model by providing mandatory access control (MAC).  It has been included in
 the mainline Linux kernel since version 2.6.36 and its development has been
 supported by Canonical since 2009.")
-    (license license:lgpl2.1)))
+    (license license:lgpl2.1)
+    (supported-systems (filter (lambda (system)
+                                 (string-suffix? "-linux" system))
+                               %supported-systems))))
 
 (define-public apparmor
   (let ((base libapparmor))