summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/astronomy.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f5509dab10..132013b57a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -121,7 +121,7 @@ programs for the manipulation and analysis of astronomical data.")
 (define-public stellarium
   (package
     (name "stellarium")
-    (version "0.15.2")
+    (version "0.16.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/stellarium/"
@@ -129,10 +129,11 @@ programs for the manipulation and analysis of astronomical data.")
                                  version "/stellarium-" version ".tar.gz"))
              (sha256
               (base32
-               "19nxj482g1hh9qicgskpcgy61pri254jgxnkd10icxbnza4c0hv9"))))
+               "1krxj51lix096xbz64lys166a8zdwhill5vvs7dlxdn14amc8d98"))))
     (build-system cmake-build-system)
     (inputs
      `(("qtbase" ,qtbase)
+       ("qtlocation" ,qtlocation)
        ("qtmultimedia" ,qtmultimedia)
        ("qtscript" ,qtscript)
        ("qtserialport" ,qtserialport)
@@ -145,13 +146,10 @@ programs for the manipulation and analysis of astronomical data.")
     (arguments
       `(#:test-target "tests"
         #:phases (modify-phases %standard-phases
-                   (add-after 'unpack 'patch-version-check
+                   (add-after 'unpack 'patch-tests
                      (lambda _
-                       ;; Previously-deprecated cmake variable vanished in
-                       ;; Qt 5.9.
-                       ;; See <https://bugreports.qt.io/browse/QTBUG-60936>.
-                       (substitute* "CMakeLists.txt"
-                         (("Qt5Core_VERSION_STRING") "Qt5Core_VERSION"))
+                       (substitute* "src/tests/testStelSphereGeometry.cpp"
+                         (("Vec3d v[(]0[)]") "Vec3d v(0.0)"))
                        #t))
                    (add-before 'check 'set-offscreen-display
                      (lambda _