summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gdb.scm18
-rw-r--r--gnu/packages/rust.scm2
2 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 56d37960f7..f2f272cc90 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -122,11 +122,18 @@ the program is running to try to fix bugs.  It can be used to debug programs
 written in C, C++, Ada, Objective-C, Pascal and more.")
     (license gpl3+)))
 
+(define-public gdb-minimal
+  (package/inherit
+   gdb
+   (name "gdb-minimal")
+   (inputs (fold alist-delete (package-inputs gdb)
+                 '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
+
 ;; This version of GDB is required by some of the Rust compilers, see
 ;; <https://bugs.gnu.org/37810>.
-(define-public gdb-8.2
+(define-public gdb-minimal-8.2
   (package
-    (inherit gdb)
+    (inherit gdb-minimal)
     (version "8.2.1")
     (source (origin
               (method url-fetch)
@@ -135,10 +142,3 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
               (sha256
                (base32
                 "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
-
-(define-public gdb-minimal
-  (package/inherit
-   gdb
-   (name "gdb-minimal")
-   (inputs (fold alist-delete (package-inputs gdb)
-                 '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index b084a6df9e..fe43e72421 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -828,7 +828,7 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
       (native-inputs
        ;; FIXME: Rust 1.27 and some later versions require GDB 8.2 specifically.
        ;; See <https://bugs.gnu.org/37810>.
-       (alist-replace "gdb" (list gdb-8.2)
+       (alist-replace "gdb" (list gdb-minimal-8.2)
                       (package-native-inputs base-rust)))
       (arguments
        (substitute-keyword-arguments (package-arguments base-rust)