summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/file-systems.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index d77d3be068..a792bd8700 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -428,7 +428,9 @@ from a mounted file system.")
                      "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
                      (string-append "CC=" #$(cc-for-target))
                      (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
-                     "PYTEST=pytest")
+                     (string-append "PYTEST_CMD="
+                                    #$(this-package-native-input "python-pytest")
+                                    "/bin/pytest"))
              #:phases
              #~(modify-phases %standard-phases
                  (delete 'configure)    ; no configure script
@@ -444,8 +446,7 @@ from a mounted file system.")
                            ,(list (string-append #$output            "/sbin")
                                   (string-append #$coreutils-minimal "/bin")
                                   (string-append #$gawk              "/bin")
-                                  (string-append #$util-linux        "/bin"))))))))
-             #:tests? #f))                  ; XXX 6 valgrind tests fail
+                                  (string-append #$util-linux        "/bin"))))))))))
       (native-inputs
        (append
          (list pkg-config