summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm81
1 files changed, 40 insertions, 41 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b498f29f63..b5ab1e7904 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23035,53 +23035,52 @@ without disturbing alignment.")
     (license license:gpl3+)))
 
 (define-public emacs-macrostep
-  (let ((commit "424e3734a1ee526a1bd7b5c3cd1d3ef19d184267"))
-    (package
-      (name "emacs-macrostep")
-      (version (git-version "0.9" "1" commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/joddie/macrostep")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1fm40mxdn289cyzgw992223dgrjmwxn4q8svyyxfaxjrpb38jhjz"))))
-      (build-system emacs-build-system)
-      (arguments
-       (list
-        #:tests? #t
-        #:phases
-        #~(modify-phases %standard-phases
-            (add-before 'check 'remove-test
-              ;; Fails because of requirement ‘/bin/sh’.
-              (lambda _
-                (let ((file "macrostep-test.el"))
-                  (make-file-writable file)
-                  (emacs-batch-edit-file file
-                    `(progn (progn (goto-char (point-min))
-                                   (re-search-forward
-                                    "(ert-deftest macrostep-expand-c-macros")
-                                   (beginning-of-line)
-                                   (kill-sexp))
-                            (basic-save-buffer))))))
-            (replace 'check
-              (lambda* (#:key tests? #:allow-other-keys)
-                (when tests?
-                  (invoke "emacs" "--batch" "-L" "."
-                          "-l" "macrostep-test.el"
-                          "-f" "ert-run-tests-batch-and-exit")))))))
-      (home-page "https://github.com/joddie/macrostep")
-      (synopsis "Interactive macro-expander for Emacs")
-      (description "@code{macrostep} is an Emacs minor mode for interactively
+  (package
+    (name "emacs-macrostep")
+    (version "0.9.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacsorphanage/macrostep")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1sxvp1q8naf0328l9fs90nk8bzsv485sajx4khh77nwkz3v4sr9f"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:tests? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'remove-test
+            ;; Fails because of requirement ‘/bin/sh’.
+            (lambda _
+              (let ((file "macrostep-test.el"))
+                (make-file-writable file)
+                (emacs-batch-edit-file file
+                  `(progn (progn (goto-char (point-min))
+                                 (re-search-forward
+                                  "(ert-deftest macrostep-expand-c-macros")
+                                 (beginning-of-line)
+                                 (kill-sexp))
+                          (basic-save-buffer))))))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "emacs" "--batch" "-L" "."
+                        "-l" "macrostep-test.el"
+                        "-f" "ert-run-tests-batch-and-exit")))))))
+    (home-page "https://github.com/emacsorphanage/macrostep")
+    (synopsis "Interactive macro-expander for Emacs")
+    (description "@code{macrostep} is an Emacs minor mode for interactively
 stepping through the expansion of macros in Emacs Lisp source code.  It lets
 you see exactly what happens at each step of the expansion process by
 pretty-printing the expanded forms inline in the source buffer, which is
 temporarily read-only while macro expansions are visible.  You can expand and
 collapse macro forms one step at a time, and evaluate or instrument the
 expansions for debugging with Edebug as normal.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-macrostep-geiser
   ;; XXX: Upstream does not tag commits (yet).  The commit below matches the