summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/statistics.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 91d988ebd4..1697ce258e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -58,11 +58,16 @@
                             (assoc-ref %outputs "out")
                             "/lib/R/lib"))
        #:phases
-       (alist-cons-before
-        'check 'set-timezone
-        ;; Some tests require the timezone to be set.
-        (lambda _ (setenv "TZ" "UTC"))
-        %standard-phases)
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'set-default-pager
+          ;; Set default pager to "cat", because otherwise it is "false",
+          ;; making "help()" print nothing at all.
+          (lambda _ (setenv "PAGER" "cat") #t))
+         (add-before
+          'check 'set-timezone
+          ;; Some tests require the timezone to be set.
+          (lambda _ (setenv "TZ" "UTC") #t)))
        #:configure-flags
        '("--with-blas"
          "--with-lapack"