summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lua.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index edb3f85109..0a1ca19a6f 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -51,6 +51,7 @@
   #:use-module (gnu packages m4)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages re2c)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages tls)
@@ -1107,14 +1108,14 @@ shell command executions.")
 (define-public emilua
   (package
    (name "emilua")
-   (version "0.2.1")
+   (version "0.3.0")
    (source (origin
             (method git-fetch)
             (uri (git-reference
                   (url "https://gitlab.com/emilua/emilua.git")
                   (commit (string-append "v" version))
-                  ;; Current version requires bundled CLI11 and fmt, but at some
-                  ;; future release the ones found in the system could be used
+                  ;; Current version requires bundled CLI11, but at some future
+                  ;; release the one found in the system could be used
                   ;; instead. Current version also requires Trial.Protocol and
                   ;; the HTTP lib developed as part of GSoC 2014 for Boost, but
                   ;; these are dependencies unlikely to be "unbundled" in future
@@ -1123,13 +1124,17 @@ shell command executions.")
             (file-name (git-file-name name version))
             (sha256
              (base32
-              "1d6k5v6x85fbvz2ijq1imnfdwvqmsav4xp021a5v3ah4mgy7yann"))))
+              "124fj73722c03znwdyqp1i0jygwv3s11f6s1j9rzym513qrf7fnd"))))
    (build-system meson-build-system)
    (arguments
     `(#:meson ,meson-0.55
       ;; Tests are disabled for now due to an issue that affecs guix:
       ;; <https://gitlab.com/emilua/emilua/-/issues/22>
-      #:configure-flags '("-Denable_http=false" "-Denable_tests=false")))
+      #:configure-flags
+      (list "-Denable_http=true"
+            "-Denable_tests=false"
+            "-Denable_manpages=false"
+            "-Dversion_suffix=-guix1")))
    (native-inputs
     `(("gcc" ,gcc-10) ; gcc-7 is too old for our C++17 needs
       ("luajit-lua52-openresty" ,luajit-lua52-openresty)
@@ -1139,6 +1144,7 @@ shell command executions.")
    (inputs
     `(("boost" ,boost)
       ("boost-static" ,boost-static)
+      ("fmt" ,fmt)
       ;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
       ;; fork. Emilua is severely affected by this limit, so the upstream package
       ;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT
@@ -1150,6 +1156,12 @@ shell command executions.")
       ("luajit-lua52-openresty" ,luajit-lua52-openresty)
       ("ncurses" ,ncurses)
       ("openssl" ,openssl)))
+   (native-search-paths
+    (list
+     (search-path-specification
+      (variable "EMILUA_PATH")
+      (files
+       (list (string-append "lib/emilua-" (version-major+minor version)))))))
    (home-page "https://gitlab.com/emilua/emilua")
    (synopsis "Lua execution engine")
    (description