summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/inkscape.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index ffd5f60b38..de9940df1c 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -80,8 +80,13 @@
     ;; FIXME: tests require gmock
     (arguments
      `(#:tests? #f
-       #:make-flags
-       '("gtk_update_icon_cache=true")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-icon-cache-generator
+           (lambda _
+             (substitute* "share/icons/application/CMakeLists.txt"
+              (("gtk-update-icon-cache") "true"))
+             #t)))))
     (home-page "https://inkscape.org/")
     (synopsis "Vector graphics editor")
     (description "Inkscape is a vector graphics editor.  What sets Inkscape