summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/boost.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 3e8d2b8a02..1767681955 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -53,7 +53,7 @@
               ;; Boost's 'context' library is not yet supported on mips64, so
               ;; we disable it.  The 'coroutine' library depends on 'context',
               ;; so we disable that too.
-              ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+              ,@(if (string-prefix? "mips64" (or (%current-target-system)
                                                  (%current-system)))
                     '("--without-context" "--without-coroutine")
                     '()))))