summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/messaging.scm6
-rw-r--r--gnu/packages/patches/bitlbee-configure-doc-fix.patch15
3 files changed, 19 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 5ba48d15d2..a26686b81b 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -387,6 +387,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/bigloo-gc-shebangs.patch			\
   gnu/packages/patches/binutils-ld-new-dtags.patch		\
   gnu/packages/patches/binutils-loongson-workaround.patch	\
+  gnu/packages/patches/bitlbee-configure-doc-fix.patch		\
   gnu/packages/patches/calibre-drop-unrar.patch			\
   gnu/packages/patches/calibre-no-updates-dialog.patch		\
   gnu/packages/patches/cdparanoia-fpic.patch			\
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index fd857b1ec3..99c5bdb0ff 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -86,20 +86,20 @@ providing:
 (define-public bitlbee
   (package
     (name "bitlbee")
-    (version "3.2.2")
+    (version "3.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://get.bitlbee.org/src/bitlbee-"
                                   version ".tar.gz"))
               (sha256
-               (base32 "13jmcxxgli82wb2n4hs091159xk8rgh7nb02f478lgpjh6996f5s"))))
+               (base32 "0plx4dryf8i6hz7vghg84z5f6w6rkw1l8ckl4c4wh5zxpd3ddfnf"))
+              (patches (list (search-patch "bitlbee-configure-doc-fix.patch")))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("check" ,check)))
     (inputs `(("glib" ,glib)
               ("libotr" ,libotr)
               ("gnutls" ,gnutls)
-              ("zlib" ,zlib)  ; Needed to satisfy "pkg-config --exists gnutls"
               ("python" ,python-2)
               ("perl" ,perl)))
     (arguments
diff --git a/gnu/packages/patches/bitlbee-configure-doc-fix.patch b/gnu/packages/patches/bitlbee-configure-doc-fix.patch
new file mode 100644
index 0000000000..ade0b7f25c
--- /dev/null
+++ b/gnu/packages/patches/bitlbee-configure-doc-fix.patch
@@ -0,0 +1,15 @@
+Fix the check for the prebuilt helpfile when xsltproc is not available.
+
+--- bitlbee-3.4/configure.orig	2015-03-25 18:09:10.000000000 -0400
++++ bitlbee-3.4/configure	2015-05-20 14:51:33.627975970 -0400
+@@ -650,8 +650,8 @@
+ 
+ if [ "$doc" = "1" ]; then
+ 	if [ ! -e doc/user-guide/help.txt ] && \
+-	     ! type xmlto > /dev/null 2> /dev/null || \
+-	     ! type xsltproc > /dev/null 2> /dev/null
++	     (! type xmlto > /dev/null 2> /dev/null || \
++	      ! type xsltproc > /dev/null 2> /dev/null)
+ 	then
+ 		echo
+ 		echo 'WARNING: Building from an unreleased source tree without prebuilt helpfile.'