summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bootstrap.scm9
-rw-r--r--guix/packages.scm2
-rw-r--r--tests/packages.scm2
3 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 22ee98879a..ffe1ec6528 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -104,7 +104,8 @@ check whether everything is alright."
        ("tarball" ,(bootstrap-origin (source* (%current-system))))))
     (synopsis description*)
     (description #f)
-    (home-page #f)))
+    (home-page #f)
+    (license #f)))
 
 (define package-with-bootstrap-guile
   (memoize
@@ -284,7 +285,8 @@ $out/bin/guile --version~%"
                           "08hv8i0axwnihrcgbz19x0a7s6zyv3yx38x8r29liwl8h82x9g88")))))))))
     (synopsis "Bootstrap binaries and headers of the GNU C Library")
     (description #f)
-    (home-page #f)))
+    (home-page #f)
+    (license lgpl2.1+)))
 
 (define %bootstrap-gcc
   ;; The initial GCC.  Uses binaries from a tarball typically built by
@@ -351,7 +353,8 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
                           "06wqs0xxnpw3hn0xjb4c9cs0899p1xwkcysa2rvzhvpra0c5vsg2")))))))))
     (synopsis "Bootstrap binaries of the GNU Compiler Collection")
     (description #f)
-    (home-page #f)))
+    (home-page #f)
+    (license gpl3+)))
 
 (define %bootstrap-inputs
   ;; The initial, pre-built inputs.  From now on, we can start building our
diff --git a/guix/packages.scm b/guix/packages.scm
index 51984baa3b..81f09d638e 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -135,7 +135,7 @@ representation."
 
   (synopsis package-synopsis)                    ; one-line description
   (description package-description)              ; one or two paragraphs
-  (license package-license (default '()))
+  (license package-license)
   (home-page package-home-page)
   (platforms package-platforms (default '()))
   (maintainers package-maintainers (default '()))
diff --git a/tests/packages.scm b/tests/packages.scm
index f441532d22..c5d9d280ed 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -49,7 +49,7 @@
   (package (name name*) (version "0") (source #f)
            (build-system gnu-build-system)
            (synopsis #f) (description #f)
-           (home-page #f)
+           (home-page #f) (license #f)
            extra-fields ...))
 
 (test-assert "package-transitive-inputs"