summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/assembly.scm22
-rw-r--r--gnu/packages/lightning.scm44
3 files changed, 22 insertions, 45 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 58f66ec878..ab0cf49b24 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -206,7 +206,6 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/libusb.scm			\
   %D%/packages/libunwind.scm			\
   %D%/packages/libupnp.scm			\
-  %D%/packages/lightning.scm			\
   %D%/packages/links.scm			\
   %D%/packages/linux.scm			\
   %D%/packages/lirc.scm				\
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 8c9b6b30fe..c80b8af329 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
@@ -90,3 +91,24 @@ Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
 debugging information in STABS, DWARF 2, and CodeView 8 formats.")
     (license (license:non-copyleft "file://COPYING"
                                    "See COPYING in the distribution."))))
+
+(define-public lightning
+  (package
+    (name "lightning")
+    (version "2.1.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/lightning/lightning-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "19j9nwl88k660045s40cbz5zrl1wpd2mcxnnc8qqnnaj311a58qz"))))
+    (build-system gnu-build-system)
+    (synopsis "Library for generating assembly code at runtime")
+    (description
+     "GNU Lightning is a library that generates assembly language code at
+run-time.  Thus, it is useful in creating Just-In-Time compilers.  It
+abstracts over the target CPU by exposing a standardized RISC instruction set
+to the clients.")
+    (home-page "http://www.gnu.org/software/lightning/")
+    (license gpl3+)))
diff --git a/gnu/packages/lightning.scm b/gnu/packages/lightning.scm
deleted file mode 100644
index 7dacb8f4cd..0000000000
--- a/gnu/packages/lightning.scm
+++ /dev/null
@@ -1,44 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages lightning)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu)
-  #:use-module (guix licenses))
-
-(define-public lightning
-  (package
-    (name "lightning")
-    (version "2.1.0")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/lightning/lightning-"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "19j9nwl88k660045s40cbz5zrl1wpd2mcxnnc8qqnnaj311a58qz"))))
-    (build-system gnu-build-system)
-    (synopsis "Library for generating assembly code at runtime")
-    (description
-     "GNU Lightning is a library that generates assembly language code at
-run-time.  Thus, it is useful in creating Just-In-Time compilers.  It
-abstracts over the target CPU by exposing a standardized RISC instruction set
-to the clients.")
-    (home-page "http://www.gnu.org/software/lightning/")
-    (license gpl3+)))