summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/enlightenment.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index f8117ac46e..a8187f8f85 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -116,12 +116,11 @@
     (arguments
      `(#:configure-flags '("--disable-silent-rules")
        #:phases
-       (alist-cons-before
-        'configure 'patch-config-files
-        (lambda _
-          (substitute* "po/Makefile.in.in"
-            (("/bin/sh") (which "bash"))))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-config-files
+           (lambda _
+             (substitute* "po/Makefile.in.in"
+                          (("/bin/sh") (which "bash"))))))))
     (home-page "http://www.enlightenment.org")
     (synopsis "Enlightenment Foundation Libraries")
     (description