summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 88864dc277..c6ff788b0d 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -139,11 +139,16 @@ a server that supports the SSH-2 protocol.")
    (build-system gnu-build-system)
    (inputs `(("groff" ,groff)
              ("openssl" ,openssl)
+             ("pam" ,linux-pam)
              ("zlib" ,zlib)
              ("xauth" ,xauth)))                   ;for 'ssh -X' and 'ssh -Y'
    (arguments
     `(#:test-target "tests"
-      #:configure-flags '("--sysconfdir=/etc")
+      #:configure-flags '("--sysconfdir=/etc"
+
+                          ;; Enable PAM support in sshd.
+                          "--with-pam")
+
       #:phases
       (modify-phases %standard-phases
         (add-after 'configure 'reset-/var/empty