summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 55e5037aba..f7af1a30da 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -200,18 +200,7 @@ the Nix package manager.")
                             (chmod po #o666))
                           (find-files "." "\\.po$"))
 
-                (zero? (system* "sh" "bootstrap"))))
-             (add-after
-              'unpack 'disable-container-tests
-              ;; XXX FIXME: These tests fail within the build container.
-              (lambda _
-                (substitute* "tests/syscalls.scm"
-                  (("^\\(test-assert \"(clone|setns|pivot-root)\"" all)
-                   (string-append "(test-skip 1)\n" all)))
-                (substitute* "tests/containers.scm"
-                  (("^\\(test-assert" all)
-                   (string-append "(test-skip 1)\n" all)))
-                #t))))))
+                (zero? (system* "sh" "bootstrap"))))))))
       (native-inputs
        `(("autoconf" ,(autoconf-wrapper))
          ("automake" ,automake)