summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/onc-rpc.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 0bcc885c39..8ef3e9f112 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -43,6 +43,14 @@
        (modify-phases %standard-phases
          (add-after 'unpack 'remote-dangling-symlink
            (lambda _
+             (substitute* '("man/netconfig.5"
+                            "man/getnetconfig.3t"
+                            "man/getnetpath.3t"
+                            "man/rpc.3t"
+                            "src/getnetconfig.c"
+                            "tirpc/netconfig.h")
+               (("/etc/netconfig") (string-append %output "/etc/netconfig")))
+
              ;; Remove the dangling symlinks since it breaks the
              ;; 'patch-source-shebangs' file tree traversal.
              (delete-file "INSTALL"))))))