summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm19
-rw-r--r--gnu/packages/patches/openblas-fix-tests-i686.patch35
3 files changed, 2 insertions, 53 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index cde94f4cf8..229d869c8f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -980,7 +980,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/omake-fix-non-determinism.patch	\
   %D%/packages/patches/ola-readdir-r.patch			\
   %D%/packages/patches/opencascade-oce-glibc-2.26.patch		\
-  %D%/packages/patches/openblas-fix-tests-i686.patch		\
   %D%/packages/patches/openexr-missing-samples.patch		\
   %D%/packages/patches/openfoam-4.1-cleanup.patch			\
   %D%/packages/patches/openldap-CVE-2017-9287.patch		\
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1e0e1998db..0191c1ce1c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2798,7 +2798,7 @@ parts of it.")
 (define-public openblas
   (package
     (name "openblas")
-    (version "0.3.0")
+    (version "0.3.1")
     (source
      (origin
        (method url-fetch)
@@ -2807,7 +2807,7 @@ parts of it.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "14a9vyvp2k5zpd0axbnqk0d3khc1v3cck10nb5fj7d2sgn8490ky"))))
+         "1ly170gcdy0rgppfw1xn5yhjfzfqkka1gpggvvbls7138qbj7y9r"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -2846,16 +2846,6 @@ parts of it.")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
-         ;; Conditionally apply a patch on i686 to avoid rebuilding
-         ;; all architectures.  FIXME: This should be moved to the
-         ;; (source (patches ...)) field in the next rebuild cycle.
-         ,@(if (string-prefix? "i686" (or (%current-target-system)
-                                          (%current-system)))
-               `((add-after 'unpack 'fix-tests
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     (invoke "patch" "-p1"
-                             "--input" (assoc-ref inputs "i686-fix-tests.patch")))))
-               '())
          (add-before 'build 'set-extralib
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Get libgfortran found when building in utest.
@@ -2867,11 +2857,6 @@ parts of it.")
      `(("fortran-lib" ,gfortran "lib")))
     (native-inputs
      `(("cunit" ,cunit)
-       ,@(if (string-prefix? "i686" (or (%current-target-system)
-                                        (%current-system)))
-             `(("i686-fix-tests.patch"
-                ,(search-patch "openblas-fix-tests-i686.patch")))
-             '())
        ("fortran" ,gfortran)
        ("perl" ,perl)))
     (home-page "http://www.openblas.net/")
diff --git a/gnu/packages/patches/openblas-fix-tests-i686.patch b/gnu/packages/patches/openblas-fix-tests-i686.patch
deleted file mode 100644
index 3325546ea3..0000000000
--- a/gnu/packages/patches/openblas-fix-tests-i686.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Fix a test failure on some i686 systems:
-
-https://github.com/xianyi/OpenBLAS/issues/1575
-
-This patch is a squashed version of these commits:
-
-https://github.com/xianyi/OpenBLAS/pull/1583
-
-diff --git a/kernel/x86/KERNEL.NEHALEM b/kernel/x86/KERNEL.NEHALEM
-index 835520ef..65b03ae5 100644
---- a/kernel/x86/KERNEL.NEHALEM
-+++ b/kernel/x86/KERNEL.NEHALEM
-@@ -1,3 +1 @@
- include $(KERNELDIR)/KERNEL.PENRYN
--SSWAPKERNEL  = ../arm/swap.c
--DSWAPKERNEL  = ../arm/swap.c
-diff --git a/kernel/x86/swap.S b/kernel/x86/swap.S
-index 54b00b33..e30c2789 100644
---- a/kernel/x86/swap.S
-+++ b/kernel/x86/swap.S
-@@ -138,6 +138,14 @@
- /* INCX != 1 or INCY != 1 */
- 
- .L14:
-+	cmpl	$0, %ebx
-+	jne	.L141
-+	cmpl	$0, %ecx
-+	jne	.L141
-+/* INCX == 0 and INCY == 0 */
-+	jmp	.L27
-+
-+.L141:
- 	movl	%edx, %eax
- 	sarl	$2,   %eax
- 	jle	.L28