summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/markup.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 2717ac35cd..6f1f9f6f68 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -23,6 +23,7 @@
 (define-module (gnu packages markup)
   #:use-module (guix licenses)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
@@ -227,12 +228,13 @@ for parsing and rendering CommonMark.")
     (version "1.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/Gottox/smu/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Gottox/smu.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "194kc08070g70ax9lg7jcr6iancbmgfgims8zfkpj9lnb3wiifzk"))))
+        (base32 "1jm7lhnzjx4q7gcwlkvsbffcy0zppywyh50d71ami6dnq182vvcc"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags (list "CC=gcc"