summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/education.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 72cd7c61ba..03050ffd0a 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -216,7 +217,7 @@ Currently available boards include:
                (substitute* "def/defines.h"
                  (("\"/usr/") (string-append "\"" out "/")))
                ;; Recreate Makefile
-               (zero? (system* "qmake"))))))))
+               (invoke "qmake")))))))
     (inputs
      `(("qt4" ,qt-4)
        ("sqlite" ,sqlite)))