summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/lighting.scm4
2 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9df42febd5..94832b357e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11659,7 +11659,7 @@ game.")  ;thanks to Debian for description
        ("gsasl" ,gsasl)
        ("libgcrypt" ,libgcrypt)
        ("libircclient" ,libircclient)
-       ("protobuf" ,protobuf-2)
+       ("protobuf" ,protobuf-2)         ; remove package when no longer needed
        ("qtbase" ,qtbase)
        ("sdl" ,(sdl-union (list sdl sdl-mixer)))
        ("sqlite" ,sqlite)
diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index 027c08b4e9..4718795a8a 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -70,9 +70,7 @@
          ("libuuid" ,util-linux "lib")
          ("zlib" ,zlib)))
       (propagated-inputs
-       ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
-       ;; XXX Remove protobuf-2 when it is no longer needed.
-       `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
+       `(("protobuf" ,protobuf)))       ; for pkg-config --libs libola
       (arguments
        `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
          ;; build to fail on low memory systems.  We disable that with the