summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am15
-rw-r--r--distro/packages/base.scm36
-rwxr-xr-xdistro/packages/bootstrap/i686-linux/bashbin0 -> 1331220 bytes
-rwxr-xr-xdistro/packages/bootstrap/i686-linux/mkdirbin0 -> 725756 bytes
-rwxr-xr-xdistro/packages/bootstrap/i686-linux/tarbin0 -> 1140196 bytes
-rwxr-xr-xdistro/packages/bootstrap/i686-linux/xzbin0 -> 865372 bytes
7 files changed, 43 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
index 0298a697f4..816660ecd1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -46,3 +46,4 @@ config.cache
 /doc/version.texi
 /distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz
 /guix-download
+/distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz
diff --git a/Makefile.am b/Makefile.am
index 623a07a7f1..35c477ea6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ dist_patch_DATA =					\
 
 bootstrapdir = $(pkgdatadir)/bootstrap
 bootstrap_x86_64_linuxdir = $(bootstrapdir)/x86_64-linux
+bootstrap_i686_linuxdir = $(bootstrapdir)/i686-linux
 
 dist_bootstrap_x86_64_linux_DATA =		\
   distro/packages/bootstrap/x86_64-linux/bash	\
@@ -73,12 +74,22 @@ dist_bootstrap_x86_64_linux_DATA =		\
   distro/packages/bootstrap/x86_64-linux/tar	\
   distro/packages/bootstrap/x86_64-linux/xz
 
+dist_bootstrap_i686_linux_DATA =		\
+  distro/packages/bootstrap/i686-linux/bash	\
+  distro/packages/bootstrap/i686-linux/mkdir	\
+  distro/packages/bootstrap/i686-linux/tar	\
+  distro/packages/bootstrap/i686-linux/xz
+
 # Big bootstrap binaries are not included in the tarball.  Instead, they
 # are downloaded.
 nodist_bootstrap_x86_64_linux_DATA =					\
   distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz
+nodist_bootstrap_i686_linux_DATA =					\
+  distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz
 
-DISTCLEANFILES = $(nodist_bootstrap_x86_64_linux_DATA)
+DISTCLEANFILES =				\
+  $(nodist_bootstrap_x86_64_linux_DATA)		\
+  $(nodist_bootstrap_i686_linux_DATA)
 
 # Method to download a file from an external source.
 DOWNLOAD_FILE =								\
@@ -88,6 +99,8 @@ DOWNLOAD_FILE =								\
 
 distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz: guix/utils.go
 	$(DOWNLOAD_FILE) "$@" "0467a82cbe4136f60a79eb4176011bf88cf28ea19c9ad9defa365811ff8e11cf"
+distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz: guix/utils.go
+	$(DOWNLOAD_FILE) "$@" "93b537766dfab3ad287143523751e3ec02dd32d3ccaf88ad2d31c63158f342ee"
 
 nobase_nodist_guilemodule_DATA = $(GOBJECTS)
 
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index ca85ca1f3e..dcb1ca20c8 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -1490,8 +1490,13 @@ check whether everything is alright."
                                  %bootstrap-base-url "/"
                                  system "/static-binaries.tar.xz"))
                            (sha256
-                            (base32
-                             "0azisn8l2b3cvgni9k0ahzsxs5cxrj0hmf38zgpq3k6pggk3zbfm"))))
+                            (match system
+                              ("x86_64-linux"
+                               (base32
+                                "0azisn8l2b3cvgni9k0ahzsxs5cxrj0hmf38zgpq3k6pggk3zbfm"))
+                              ("i686-linux"
+                               (base32
+                                "16v60frbh0naccanwxcxz0z3444dd8salbg8p7cp7vwz8245nhfk"))))))
                         "true"                    ; the program to test
                         "Bootstrap binaries of Coreutils, Awk, etc."))
 
@@ -1504,8 +1509,13 @@ check whether everything is alright."
                                  %bootstrap-base-url "/"
                                  system "/binutils-2.22.tar.xz"))
                            (sha256
-                            (base32
-                             "1cz1rwqhswgrr14kzbkaj3k32kzgv2b6mmzvc6ssbbz8k2m8jmqa"))))
+                            (match system
+                              ("x86_64-linux"
+                               (base32
+                                "1cz1rwqhswgrr14kzbkaj3k32kzgv2b6mmzvc6ssbbz8k2m8jmqa"))
+                              ("i686-linux"
+                               (base32
+                                "1crg5xsf4cxk249sg90h6fjhfkwj1s5dxvhwbym79g79ygbww1br"))))))
                         "ld"                      ; the program to test
                         "Bootstrap binaries of the GNU Binutils"))
 
@@ -1552,8 +1562,13 @@ check whether everything is alright."
                        (uri (string-append %bootstrap-base-url "/"
                                            system "/glibc-2.16.0.tar.xz"))
                        (sha256
-                        (base32
-                         "1cz587p3scrrx0zgqnmp4nnfj0vvf01zdqdgkz445dnbfh64nl0v"))))))))
+                        (match system
+                          ("x86_64-linux"
+                           (base32
+                            "1cz587p3scrrx0zgqnmp4nnfj0vvf01zdqdgkz445dnbfh64nl0v"))
+                          ("i686-linux"
+                           (base32
+                            "0vzybz1577vflm0p0zg1slqj32carj5102b45k7iskkj46viy14z"))))))))))
     (description "Bootstrap binaries and headers of the GNU C Library")
     (long-description #f)
     (home-page #f)))
@@ -1618,8 +1633,13 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
                        (uri (string-append %bootstrap-base-url "/"
                                            system "/gcc-4.7.2.tar.xz"))
                        (sha256
-                        (base32
-                         "07piqzcdaksjbcj037y5gdbh9dfqwzjivg6fkhgg8kif82ibwxxr"))))))))
+                        (match system
+                          ("x86_64-linux"
+                           (base32
+                            "07piqzcdaksjbcj037y5gdbh9dfqwzjivg6fkhgg8kif82ibwxxr"))
+                          ("i686-linux"
+                           (base32
+                            "0caiihphp23rrqn382cabykz9ps3ixd5p63dgdnkhz1f01jiarl2"))))))))))
     (description "Bootstrap binaries of the GNU Compiler Collection")
     (long-description #f)
     (home-page #f)))
diff --git a/distro/packages/bootstrap/i686-linux/bash b/distro/packages/bootstrap/i686-linux/bash
new file mode 100755
index 0000000000..9882d4adc7
--- /dev/null
+++ b/distro/packages/bootstrap/i686-linux/bash
Binary files differdiff --git a/distro/packages/bootstrap/i686-linux/mkdir b/distro/packages/bootstrap/i686-linux/mkdir
new file mode 100755
index 0000000000..0ddab232b7
--- /dev/null
+++ b/distro/packages/bootstrap/i686-linux/mkdir
Binary files differdiff --git a/distro/packages/bootstrap/i686-linux/tar b/distro/packages/bootstrap/i686-linux/tar
new file mode 100755
index 0000000000..6bee702cf5
--- /dev/null
+++ b/distro/packages/bootstrap/i686-linux/tar
Binary files differdiff --git a/distro/packages/bootstrap/i686-linux/xz b/distro/packages/bootstrap/i686-linux/xz
new file mode 100755
index 0000000000..5a126e4fc5
--- /dev/null
+++ b/distro/packages/bootstrap/i686-linux/xz
Binary files differ