summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lsof.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index d3f1321e06..8b3ebe2945 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -73,14 +73,16 @@
         (add-after 'configure 'patch-timestamps
           (lambda _
             (substitute* "Makefile"
-              (("`date`") "`date --date=@1`"))))
+              (("`date`") "`date --date=@1`"))
+            #t))
         (add-before 'check 'disable-failing-tests
           (lambda _
             (substitute* "tests/Makefile"
               ;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
               (("(STDTST=.*) LTsock" _ prefix) prefix)
               ;; Fails without access to a remote NFS server.
-              (("(OPTTST=.*) LTnfs"  _ prefix) prefix))))
+              (("(OPTTST=.*) LTnfs"  _ prefix) prefix))
+            #t))
         (replace 'check
           (lambda _
             (with-directory-excursion "tests"