summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tcl.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index a8c4c957c4..abd4ba5817 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -42,9 +42,17 @@
                    (chdir "unix"))
                  (alist-cons-after
                   'install 'install-private-headers
-                  (lambda _
+                  (lambda* (#:key outputs #:allow-other-keys)
                     ;; Private headers are needed by Expect.
-                    (zero? (system* "make" "install-private-headers")))
+                    (and (zero? (system* "make"
+                                         "install-private-headers"))
+                         (let ((bin (string-append (assoc-ref outputs "out")
+                                                   "/bin")))
+                           ;; Create a tclsh -> tclsh8.6 symlink.
+                           ;; Programs such as Ghostscript rely on it.
+                           (with-directory-excursion bin
+                             (symlink (car (find-files "." "tclsh"))
+                                      "tclsh")))))
                   %standard-phases))
 
        ;; XXX: There are a few test failures (related to HTTP, most