summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b1cb0c4092..80ed0bc26e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -408,3 +408,26 @@ any subsequent lookup as it keeps the hash table in memory.")
 behave (almost) as if they were in RAM by transparently mapping only a section
 in main memory.")
     (license license:gpl2)))
+
+(define-public r-ffbase
+  (package
+    (name "r-ffbase")
+    (version "0.12.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ffbase" version))
+       (sha256
+        (base32
+         "1nz97bndxxkzp8rq6va8ff5ky9vkaib1jybm6j852awwb3n9had5"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bit" ,r-bit)
+       ("r-fastmatch" ,r-fastmatch)
+       ("r-ff" ,r-ff)))
+    (home-page "http://github.com/edwindj/ffbase")
+    (synopsis "Basic statistical functions for package 'ff'")
+    (description
+     "This package extends the out of memory vectors of @code{ff} with
+statistical functions and other utilities to ease their usage.")
+    (license license:gpl3)))