summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1cf80cfb3f..fac0cbbae3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -276,11 +276,14 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
                            #:key
                            ;; A function that takes an arch and a variant.
                            ;; See kernel-config for an example.
+                           (extra-version #f)
                            (configuration-file #f)
                            (defconfig "defconfig")
                            (extra-options %default-extra-linux-options))
   (package
-    (name "linux-libre")
+    (name (if extra-version
+              (string-append "linux-libre-" extra-version)
+              "linux-libre"))
     (version version)
     (source (origin
               (method url-fetch)
@@ -327,6 +330,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
                  (format #t "`CROSS_COMPILE' set to `~a'~%"
                          (getenv "CROSS_COMPILE"))))
 
+             (setenv "EXTRA_VERSION" ,extra-version)
+
              (let ((build  (assoc-ref %standard-phases 'build))
                    (config (assoc-ref inputs "kconfig")))