summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2c2cead112..26c193fe4e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4319,6 +4319,26 @@ clock speed.")
                               "Sys-CPU-" version))
     (license (package-license perl))))
 
+(define-public perl-sys-hostname-long
+  (package
+    (name "perl-sys-hostname-long")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SC/SCOTT/"
+                           "Sys-Hostname-Long-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1jv5n8jv48c1p8svjsigyxndv1ygsq8wgwj9c7ypx1vaf3rns679"))))
+    (build-system perl-build-system)
+    (arguments `(#:tests? #f))          ;no `hostname' during build
+    (home-page "http://search.cpan.org/dist/Sys-Hostname-Long")
+    (synopsis "Get full hostname in Perl")
+    (description "Sys::Hostname::Long tries very hard to get the full hostname
+of a system.")
+    (license (package-license perl))))
+
 (define-public perl-task-weaken
   (package
     (name "perl-task-weaken")