summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am15
-rw-r--r--configure.ac5
-rw-r--r--m4/guix.m413
3 files changed, 1 insertions, 32 deletions
diff --git a/Makefile.am b/Makefile.am
index 8fd1c1b0b6..fd76be4d72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,6 +101,7 @@ MODULES =					\
   guix/build/rpath.scm				\
   guix/build/cvs.scm				\
   guix/build/svn.scm				\
+  guix/build/syscalls.scm                       \
   guix/build/gremlin.scm			\
   guix/build/emacs-utils.scm			\
   guix/build/graft.scm				\
@@ -157,13 +158,6 @@ MODULES +=					\
 
 endif
 
-if BUILD_SYSCALLS_MODULE
-
-MODULES +=					\
-  guix/build/syscalls.scm
-
-endif
-
 if BUILD_DAEMON_OFFLOAD
 
 MODULES +=					\
@@ -384,13 +378,6 @@ EXTRA_DIST +=					\
 
 endif !BUILD_DAEMON_OFFLOAD
 
-if !BUILD_SYSCALLS_MODULE
-
-EXTRA_DIST +=					\
-  guix/build/syscalls.scm
-
-endif !BUILD_SYSCALLS_MODULE
-
 
 CLEANFILES =					\
   $(GOBJECTS)					\
diff --git a/configure.ac b/configure.ac
index 7c6fcc9ec9..1f5c549aee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,11 +86,6 @@ dnl Check whether (srfi srfi-37) works, and provide our own if it doesn't.
 GUIX_CHECK_SRFI_37
 AM_CONDITIONAL([INSTALL_SRFI_37], [test "x$ac_cv_guix_srfi_37_broken" = xyes])
 
-dnl Check whether (guix build syscalls) can be built.
-GUIX_CHECK_LIBC_MOUNT
-AM_CONDITIONAL([BUILD_SYSCALLS_MODULE],
-  [test "x$guix_cv_libc_has_mount" = "xyes"])
-
 dnl Decompressors, for use by the substituter and other modules.
 AC_PATH_PROG([GZIP], [gzip])
 AC_PATH_PROG([BZIP2], [bzip2])
diff --git a/m4/guix.m4 b/m4/guix.m4
index 2d3dfd282e..654789e1d9 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -280,19 +280,6 @@ AC_DEFUN([GUIX_ASSERT_CXX11], [
   fi
 ])
 
-dnl GUIX_CHECK_LIBC_MOUNT
-dnl
-dnl Check whether libc provides 'mount'.  On GNU/Hurd it doesn't (yet).
-AC_DEFUN([GUIX_CHECK_LIBC_MOUNT], [
-  AC_CACHE_CHECK([whether libc provides 'mount'], [guix_cv_libc_has_mount],
-    [GUILE_CHECK([retval], [(dynamic-func \"mount\" (dynamic-link))])
-     if test "$retval" = 0; then
-       guix_cv_libc_has_mount="yes"
-     else
-       guix_cv_libc_has_mount="no"
-     fi])
-])
-
 dnl GUIX_LIBGCRYPT_LIBDIR VAR
 dnl
 dnl Attempt to determine libgcrypt's LIBDIR; store the result in VAR.